Instalasi Apache2, FastCGI, dengan Beberapa Versi PHP yang berbeda.

Terkadang perlu menginstall Apache dengan beberapa versi PHP, mengapa ? Misalnya untuk keperluan debugging. Kode yang normal berjalan di PHP 5.3.6 tetapi mengapa tidak berjalan di PHP 5.3.3 ? 

Silahkan Sahabat mencoba tutorial [1] , jika ada kesulitan, silahkan manfaatkan media milis OpenThink Labs untuk bertanya ... :)

Catatan : 

Jika menemukan Error berikut di Ubuntu 12.02 

checking for pkg-config... /usr/bin/pkg-config
configure: error: Cannot find OpenSSL's <evp.h>

Jalankan perintah berikut : 

sudo apt-get install libcurl4-openssl-dev pkg-config.



Referensi 
  1. Multiple PHP Versions with Apache 2, FastCGI, PHPFarm on Ubuntu,  http://www.metod.si/multiple-php-versions-with-apache-2-fastcgi-phpfarm-on-ubuntu/
  2. Apache2, FastCGI & Multiple PHP Versions (Ubuntu/Lucid-10.04), http://dbforch.wordpress.com/2010/05/21/apache2-fastcgi-multiple-php-versions-ubuntulucid-10-04/
  3. phpfarm, http://sourceforge.net/p/phpfarm/wiki/Home/
  4. Apache httpd + suEXEC + chroot + FastCGI + PHP, http://e.metaclarity.org/268/httpdsuexecchrootfastcgiphp/
  5. How To Set Up Apache2 With mod_fcgid And PHP5 On Ubuntu 10.10, http://www.howtoforge.com/how-to-set-up-apache2-with-mod_fcgid-and-php5-on-ubuntu-10.10

Comments